آموزش جامع و کامل نرم افزار ISE برای کار با FPGA و CPLD های شرکت Xilinx (بخش اول)

0

آموزش جامع و کامل نرم افزار ISE برای کار با FPGA و CPLD های شرکت Xilinx (بخش اول)

از نرم افزار ISE برای توسعه مدارات دیجیتال بر روی FPGA و CPLD های شرکت Xilinx استفاده می‌شود. این نرم افزار کلیه فازهای توسعه نظیر طراحی، شبیه سازی، سنتز و دیباگ را دربر می­گیرد. در این گزارش هر فاز بطور مفصل شرح داده شده است.

ایجاد پروژه جدید

اولین گام برای استفاده از نرم‌افزار ISEایجاد پروژه جدید است. برای این منظور گام‌های زیر را طی می‌شود:

ابتدا نرم افزار ISE  را اجرا کنید. نرم افزار ISE بطور پیش فرض پروژه قبلی را باز می‌کند. محیط نرم افزار ISE در شکل 1 نشان داده شده است

شکل 1- محیط نرم افزار ISE
شکل 1- محیط نرم افزار ISE
  1. مطابق شکل 2از منوی File گزینه New Project را انتخاب کنید.
شکل 2- نحوه ایجاد پروژه جدید در نرم افزار ISE بخش اول
شکل 2- نحوه ایجاد پروژه جدید در نرم افزار ISE بخش اول

در پنجره باز شده (شکل 3) نام پروژه و محل ذخیره آن را تعیین کنید. گزینه Top-Level source type را بر روی HDL تنظیم کنید. سپس بر روی دکمه Next کلیک کنید.

شکل 3- نحوه ایجاد پروژه جدید در نرم افزار ISE بخش دوم
شکل 3- نحوه ایجاد پروژه جدید در نرم افزار ISE بخش دوم
  1. در پنجره بعدی (شکل 4) FPGA موردنظر انتخاب و تنظیمات مربوط به پروژه انجام می‌شود.گزینه Simulator نیز شبیه‌ساز پروژه و قسمت Synthesis Tool ابزار سنتز را تعیین می‌کند. ISE بطور پیش فرض از ابزار ISim برای شبیه‌سازی و از XST برای سنتز استفاده می‌کند. در صورتی که بخواهید از ابزارهای دیگری نظیر ModelSim و … برای شبیه‌سازی و یا synplify و … برای سنتز استفاده کنید باید آن را از قسمت‌های Simulator و Synthesis Tool تعیین کنید.گزینه Preferred Language نیز زبان مورد نظر را تعیین می‌کند. در این گزارش از زبان Verilog استفاده شده است. پس از انجام تنظیمات موردنظر بر روی دکمه Next کلیک کنید.
شکل 4- نحوه ایجاد پروژه جدید در نرم افزار ISE بخش سوم
شکل 4- نحوه ایجاد پروژه جدید در نرم افزار ISE بخش سوم

در پنجره بعدی (شکل 5) خلاصه مشخصات پروژه نشان داده می‌شود. در صورت درست بودن مقادیر نشان داده شده بر روی دکمه Finish کلیک کنید در غیر اینصورت در روی دکمه Back کلیک کرده و تنظیمات موردنظر را مجددا تعیین کنید.

شکل 5- نحوه ایجاد پروژه جدید در نرم افزار ISE بخش چهارم
شکل 5- نحوه ایجاد پروژه جدید در نرم افزار ISE بخش چهارم

با کلیک کردن بر روی گزینه Finish، پروژه خالی ایجاد می‌شود. در شکل 6 پروژه خالی نشان داده شده است.

شکل 6- نحوه ایجاد پروژه جدید در نرم افزار ISE بخش پنجم
شکل 6- نحوه ایجاد پروژه جدید در نرم افزار ISE بخش پنجم

باز کردن پروژه

با کلیک کردن بر روی گزینه Open Project از منوی File  می‌توان پروژه موجود را باز نمود.

ایجاد فایل Verilog یا VHDL

برای ایجاد فایل Verilog یا VHDL  ابتدا از منوی Project  گزینه New Source را انتخاب کنید. (شکل 7)

کل 7- نحوه ایجاد فایل Verilog یا VHDL بخش اول
کل 7- نحوه ایجاد فایل Verilog یا VHDL بخش اول

سپس در پنجره باز شده (شکل 8) نام فایل، محل ذخیره و نوع آن را مشخص کنید. برای ایجاد فایل Verilog گزینه Verilog Module و برای ایجاد فایل VHDL گزینه VHDL Module را انتخاب کنید. سپس بر روی دکمه Next کلیک کنید.

شکل 8- نحوه ایجاد فایل Verilog یا VHDL بخش دوم
شکل 8- نحوه ایجاد فایل Verilog یا VHDL بخش دوم

در پنجره New Source Wizard  ورودی و خروجی های بلوک موردنظر را می‌توان بصورت گرافیکی تعیین کرد. با توجه با اینکه پورت‌های ماژول را می‌توان بصورت دستی به فایل اضافه نمود، لذا می­توان از این از این پنجره صرف نظر کرد. سپس بر روی دکمه Next و سپس دکمه Finish کلیک کنید. در این مرحله ISE فایل موردنظر را ایجاد کرده و به پروژه اضافه می­کند.

سپس در فایل ایجاد شده برنامه خود را اضافه کنید. در اینجا برنامه یک مالتی پلکسر سنکرون ساده نوشته شده است.

timescale 1ns / 1ps

module MU_4to1(
    input clk_in,
    input a_in,
    input b_in,
    input c_in,
    input d_in,
    input [1:0] sel_in,
    output reg [1:0] out);

wire clk;
reg a;
reg b;
reg c;
reg d;
reg [1:0] sel;

always @(posedge clk) begin
    a <= a_in;
    b <= b_in;
    c <= c_in;
    d <= d_in;
    sel <= sel_in;
end

always @(posedge clk) begin
    case (sel)
        2'b00:  out <= a;
        2'b01:  out <= b;
        2'b10:  out <= c;
        2'b11:  out <= d;
        default:    out <= a;
    endcase
end

clk_manager clk_wizard (.CLK_IN1(clk_in), .CLK_OUT1(clk));
     
endmodule
 
Choose your Reaction!
دیدگاه خود را بنویسید

آدرس ایمیل شما منتشر نخواهد شد.

redronic.com
رفتن به نوار ابزار